
 

 

 

 

❖ FOCUS OF THE CHAPTER: 

• Creating links 

• Anchor tag 

• Specifying colors for links 

• Using an image as a hyperlink 

• Frames 

• Attributes of the frameset and frame tags 

 

❖ KEYWORDS: 

• Link :  An HTML element that allows users to navigate from one page to another 

• Hyperlink:  A tag which when clicked, takes the user to another web page 

• Frameset:  A collection of many frames. 

 

❖ CHECKPOINT: 

Write T for True or F for False. 

1) Hyperlinks are used to link various web pages of a website.    T 

2) The Anchor tag is an empty tag.        F 

3) The Alink attribute is used to set the color for the visited links in a web page.  F 

4) The img src attribute is used to specify the location of an image file that is used  T 

     as a hyperlink.  

 

❖ EXERCISE CORNER: 

A. Tick ( √) the correct answers. 

 1) Which attribute is used with the Anchor tag for specifying links? 

  a) href     b) src 

  c) body    d) cols 

 2) Which of the following is not a type of link? 

  a) internal    b) global 

  c) static    d) local 

 3) Which of the following is the default color for the link attribute? 

  a) red     b) blue 

  c) green    d) purple 

 4) Which tag is used to define frames on a web page? 

  a) frameset    b) frame 

  c) table     d) src 

 5) Which attribute of the frameset tag is used to specify the thickness of the border? 

  a) bordersize    b) frameborder 

  c) border    d) border color 
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B. Name the following. 

 1) External web pages can be links using this attribute of the Anchor tag. – href attribute 

 2) This attribute of the frameset tag sets the color of a frame. - bordercolor 

 3) This attribute of the frame tag specifies the path of the file that should be displayed in the  

        frame. - src 

 4) This tag is used along with the Anchor tag for using an image as a hyperlink. - <img> 

 5) This attribute sets the color of the link when the mouse pointer is on it. - Alink 

 

C. Answer these questions. 

 1) What is a hyperlink? Name the three types of links. 

 Ans: Hyperlinks are used to link various web pages of a website. Hyperlinks are generally blue in  

          color. There are three different kinds of links available on a web page. 

  Internal – links on the same page 

  Local – links to another page within the same website 

  Global – links to pages on different websites. 

 

 2) Write an HTML code to change the default color for the three link attributes of the body tag. 

 Ans: The default color for link, alink and vlink attributes with the <body> tag is : 

  <body link=  blue alink =  red vlink = purple> 

 

 3) Write an HTML code to use an image as a hyperlink. on clicking the image, say image 1,  

the use should be directed to another image, say image 2. On clicking image 2, the user  

should be directed back to image 1. 

 Ans:  image 1 say: <a href= “C:\user\username\Desktop\image2.html”> 

  <img src= “C:\user\username\Desktop\image.jpg”></a> 

  image 2 say: <a href= “C:\user\username\Desktop\image1.html”> 

  <img src= “C:\user\username\Desktop\image.jpg”></a> 

 

 4) Use the images in question3 and display them with the help of the frames in different rows. 

 Ans: <frameset rows= “40%,60%”> 

  <frame src = “C:\user\username\Desktop\image2.html”> 

  <frame src= “C:\user\username\Desktop\image1.html”> 

  </frameset> 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

❖ FOCUS OF THE CHAPTER: 

• Retouching Tools 

• Working with Text 

• Layers 

• Working with Layers 

• Filters 

 

❖ KEYWORDS: 

• Layer:  A transparent sheet where you can edit without affecting objects on another  

  layer. 

• Filter:  An effect that can be applied to an image. 

 

❖ CHECKPOINT: 

Tick ( √) the correct answers. 

1) Which tool is used to remove spots or scratches from an image? 

 a) Spot Healing    b) Healing Brush 

 c) Clone Stamp    d) Patch 

2) Which tool is used to create new patterns? 

  a) Spot Healing    b) Healing Brush 

  c) Clone Stamp    d) Patch 

3) Which tool is used to duplicate the parts of an image? 

 a) Patch     b) Clone Stamp 

 c) Zoom     d) Type 

 

❖ EXERCISE CORNER 

A. Tick ( √) the correct answers. 

 1) Which tool will you use to remove an unwanted object from an image? 

  a) Patch     b) Zoom 

  c) Healing Brush    d) Spot Healing Brush 

 2) Which option allows you to display text in different shapes? 

  a) Filter     b) Type 

  c) Warp Text     d) Patch 

 3) Which of the following will you use to add text or effect on a transparent sheet and place it 

     over an image? 

  a) Filters     b) Layers 

  c) Zoom     d) None of these 

 4) In which panel can you change the order of the layers? 

  a) Tools     b) Options 

  c) Layers     d) Filter 

 5) Which of the following is used to change the appearance of an image? 

  a) Layer     b) Filter 

  c) Zoom     d) Warp Text 
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B. Correct the statements. 

 1) The Spot Healing Brush Tool is used to remove the unwanted elements from an image. –  

        Patch 

 2) Press CTRL + E to deselect area. – CTRL + D 

 3) To select a sample, press and hold the SHIFT key. - ALT 

 4) The Type tool is used to twist, stretch or distort text. – Warp Text Tool 

 5) You can move filters up and down. – layers 

 

C. Name the following. 

 1) Tool used to remove small spots from an image. -  Spot Healing Brush tool 

 2) Tool used to create a duplicate.  -   Clone Stamp tool 

 3) Tool used to twist text.  -    Warp Text tool 

 4) Transparent sheets placed over an image. -  Layers 

 5) Tool used to change the appearance of an image. -  Filter 

 

D. Name the tools that have been used to modify the images

  
 

 

E. Answer these questions. 

 1) What is the difference between the Spot Healing Brush Tool and the Healing Brush Tool? 

 Ans: The Spot Healing Brush Tool – The Spot Healing Brush tool is used to remove small spots 

or scratches from an image. 

 The Healing Brush tool – The Healing Bruch tool, you need to select a sample of the area that you 

want the change to look like.  

 

 2) Write the use of Clone Stamp Tool. How is it different from the Healing Brush Tool? 

 Ans: The Clone Stamp Tool is like a rubber stamp. The Clone Stamp Tool creates a duplicate of 

whatever is stored in the tool as a sample. 

 

 3) What is the use of layers? 

 Ans: The use of layers is to control how images are displayed, printed and edited in Photoshop.  

 

 4) What are filters used for? 

 Ans: Filters are tools that are used to quickly create effects on images. A filter placed over an 

image can change its appearance.   

Spot Healing Brush tool 

Patch tool 



 

 

 5) Write the steps to apply layer effects. 

 Ans:  1) Open Adobe Photoshop cs6 

  2) Click on File > Open 

  3) Select Libraries > Pictures > Sample Pictures > Tulips  

  4) Click on Open 

  5) The Tulips image will open in the Photoshop window. The Layers panel shows the 

 image on the Background layer. 

  6) In the Layer menu on the Menu Bar, choose New and then choose Layer Via Copy 

  7) Click on Layer 1 in the Layer panel to select it. The layer will be highlighted in blue. 

 From the Layer menu, choose Smart Objects and then choose Convert to Smart Object 

  8) From the Filter menu, choose Filter Gallery 

  9) Select the Artistic category at the top and then select the Dry Brush filter by clicking on  

        its thumbnail. 

  10) The options for the Dray Brush filter will then appear on the right. set both the Brush  

        Size and Brush Detail options to 10 and then set the Texture option. 

  11) Click on Ok to apply the filter and close the filter Gallery. 

  12) With layer 1 still selected, change the blend mode from Normal to Screen 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

 

❖ FOCUS OF THE CHAPTER: 

• Parts of Movie Maker window 

• Creating a movie 

• Saving a movie 

• Publishing a movie 

 

❖ KEYWORDS: 

Transition:  A special video effect that can be placed between images or video clips to 

 smoothen the sudden change between them 

Title:   A stand –alone clip meant to precede a movie. 

Credit:   A stand – alone clip meant to follow a movie.  

 

❖ CHECKPOINT: 

 

A. Tick ( √) the correct answers. 

 1) On which of the following tabs will you find the Add Music command? 

  a) Edit      b) Visual Effects 

  c) Home     d) Animations 

 2) Which tab has the option for applying transitions? 

  a) Animations     b) Visual Effects 

  c) View     d) Edit 

 

❖ EXERCISE CORNER: 

 

A. Tick ( √) the correct answers. 

 1) Which part of the Movie Maker window is used to view individual clips? 

  a) Ribbon     b) Preview monitor 

  c) Title bar     d) None of these 

 2) Which part of the Movie Maker window is used to view and arrange the sequence of the clips? 

  a) Storyboard     b) Playback button 

  c) Preview monitor    d) Ribbon 

 3) Which of the following control shows the actual position of the clip? 

  a) Widescreen     b) Playhead 

  c) Play      d) Storyboard 

 4) Which of the following are stand – alone clips meant to follow a movie? 

  a) Captions     b) Titles 

  c) Credits     d) Title bar 

 5) Which of the following groups has the option to publish a movie?   

  a) Add      b) Share 

  c) Edit      d) Clipboard 
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B. Name the following: 

 1) You can play, pause, rewind or forward a movie using these buttons. - Playback Control  

           button 

 2) You need to change this when you see black bands on top of a video. - Widescreen 

 3) This option is used to place an image in the middle of a video clip. – Split option 

 4) This is text that is added to be displayed on the top or bottom of clips or images. – Title &  

             Credits 

 5) This is a keyboard shortcut for viewing a movie in full screen. – Press F11 key 

 

C. Answer these questions. 

 1) How can black bands on the top and bottom of a video be removed? 

 Ans: Select the Widescreen option from the Project tab. The black bands disappear as we play the 

video clip. 

 

 2) Ramya has added a clip in a movie but she heard an unwanted sound in the background while 

playing the clip. How can she mute the sound? 

 Ans: To mute the sound, follow these steps: 

  1) Select the video by clicking on it. 

  2) Click on Video volume on the Edit tab. 

  3) To mute the clip, move the slider to the extreme left. 

 

 3) What are transitions used for? 

 Ans: Transitions are used for controls how a movie plays from one video clip or image to the text.  

 

 4) Differentiate between titles and credits of a movie. 

 Ans: Titles : Titles are stands –alone clips meant to precede a movie. 

          Credits: Credits are stand –alone clips meant to follow a movie. 

 

 5) List any two options to publish a movie in movie maker. 

 Ans: In the Share groups, we can choose an option to publish a movie are as below: 

  1) Facebook 

  2) YouTube 

  3) One Drive 

 

D. Number the steps in the correct order to add a title to a movie. 

 4 Enter the title of the movie. 

 2 Click on the Title button on the Home tab 

 1 Select the image before which a title is to be added 

 3 Choose an effect from the Effects group. 

 

 

 

 



 

 

 

❖ FOCUS OF THE CHAPTER: 

 

• Computer ethics 

• Internet ethics 

• intellectual property rights 

• Privacy 

• Software piracy 

• Cybercrime 

• Preventing Cybercrime 

 

❖ KEYWORDS: 

 

❖ Intellectual property rights:   The rights given to a person over her or his creation sharing a 

softlifting                               software with someone who is not authorized by the license 

           agreement 

❖ Counterfeiting :  Producing fake copies of a software in such a manner that  

    the copies look like the original software. 

❖ Phishing:   Luring a user via email to a fake website. 

❖ Pharming:   redirecting a user to a wrong website when she/he enters a  

    genuine wed address. 

❖ Hacking:   Illegally gaining access to a computer to damage or steal  

    information. 

❖ CHECKPOINT: 

Write T for True or F for False. 

1) There is no need to consider the social consequences of the work you are doing on a computer. 

 F 

2) It is improper to use pirated software.  T 

3) The files in any computer are public property. F  

4) Spreading viruses or any harmful programs in computers is unethical. T 

 

❖ EXERCISE CORNER: 

A. Tick ( √) the correct answers. 

1) Which of the following are the ten rules defined by computer Ethics Institute? 

 a) ten warriors    b) ten commandments 

 c) ten ethics    d) all of these 

2) Which of the following defines the illegal copying distrudution or use of software? 

 a) Softlifting    b) Software Piracy 

 c) Intellectual property rights  c) Hacking 

3) Which of the following defines producing fake copies of a software in such a manner that  

     they look like the original product? 

 a) Renting    b) Counterfting 

 c) Photocopy    d) Softifting 
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4) Which of the following is the symbol used to denote copyright? 

 a) ©      b) ®  

 c) @     d) TM 

B. Match the columns. 

                Ans. 

 1. Rights given to persons over their creations c  a. phishing 

 2. Luring a user to a fake website   a  b. Computer ethics 

 3. An activity of cracking passwords   d  c. Intellectual property rights 

 4. Rules and practices followed on a computer b  d. hacking 

 5. Redirecting a user to a fake website  e  e. pharming 

 

C. Define the following terms. 

 1) Copyright:  Copyright is a term used to describe the rights that creators have over their  

   contents or artistic works. 

 2) Software Piracy: Software piracy is the illegal copying, distribution or use of software 

 application  

 3) Softlifting: Softlifting means sharing a software with someone who is not authorized by the  

   license. 

 4) Identity theft: Identify theft is one of the most common forms of cybercrime. criminals use the  

       Internet to steal someone’s personal information.  

 5) Hacking: Hacking is the act of gaining access to a computer and viewing, copying or  

   creating data on it. 

 6) Phishing: In a Phishing attack, criminals lure a user via email to a fake website. 

 

D. Answer these questions. 

 

 1) Explain in brief about computer ethics. 

 Ans: Computer ethics deals with the rules and practices that you should follow while working on 

         computers. There are ten rules, commonly referred to as the ten commandments, which are 

        defined by the computer Ethics Institute located in Washington DC. These are listed as 

        follow: 

  a) You shall not use a computer to harm other people. 

  b) You shall not interfere with other people’s computer work.  

  c) You shall not snoop around in other people’s computer files. 

  d) You shall not use a computer to steal. 

  e) You shall not use a computer to bear false witness. 

  f) You shall not copy or use proprietary software for which you have not paid. 

  g) You shall not use other people’s computer resources without authorization or proper  

        compensation. 

  i) You shall not appropriate other people’s intellectual output. 

  j) You shall think about the social consequences of the program you are writing or the 

    system you are designing. 

  k) You shall always use a computer in ways that ensure consideration and respect for your 

     fellow humans. 

 

 



 

 

 2) What do you understand by the term ‘Intellectual property rights’? 

 Ans: Intellectual property refers to creations of the mind, such as invertions, literary and artistic 

 works, and images used for commercial purpose. There are laws that protect intellectual 

 property. this enables inventors, writers or artists to get recognition and financial benfit 

 from what they invent, write or create. 

 

 3) What is renting? 

 Ans: Renting is a crime to rent out or lend software without the permission of the license holder.  

  This is similar to renting out CDs or DVDs of movies. 

 

 4) Differentiate between phishing and pharming. 

 Ans: Phishing: In a phishing attack, criminals lure a user via email to fake website.  

        They create a website that looks like that of a genuine company such a s a bank.  

  Pharming : In a pharming attack, when a user enters a genuine web address, criminals 

      redirect them to a wrong website. 

 

 5) Describe in brief about identity theft. 

 Ans: Identify theft is one of the most common forms of cybercrime. criminals use the Internet to 

steal someone’s personal information. The information they steal could inclue the date of 

birth, phone number, credit card numbers, Pin of debit or credit card, Aadhaar card 

number and passwords. The stole information is then used for personal gain, such as 

obtaining new mobile connections, for online shopping and for access to bank accounts. 

                                                                                                   

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

 

❖ FOCUS OF THE CHAPTER: 

• Structure of a C++ program 

• Opening and closing a program in C++ 

• Running a program in C++ 

• Saving a program in C++ 

• Declaring variables 

• The first program in C++ 

• Using conditional statements and loops 

 

❖ KEYWORDS: 

 

• Header file: A file that holds all the declarations in a program 

• Variable: A memory location used to store a value. 

• Loop: A sequence of instructions that is repeated until a particular condition is 

satisfied. 

  

❖ EXERCISE CORNER: 

 

A. Tick ( √) the correct answers. 

 

 1) Which level of computer programming language is C++? 

  a) high level     b) low level 

  c) moderate level    d) none of these 

 2) Which keys are pressed to exit the C++ window? 

  a) CTRL + X     b) ALT + Q 

  c) ALT + X     d) ALT + Y 

 3) Which of the following has to be declared before it is used? 

  a) data      b) variable 

  c) memory     d) constant 

 4) Which of the following is stored in a float data type? 

  a) integers     b) letters 

  c) decimal numbers    d) all of these 

 

B. Fill in the blanks. 

 

1) C++ is an extension to the  C language. 

2) C++ program files are saved with the extension .cpp 

3) A variable   is a location in the computer memory. 

4) A loop refers to a sequence of instruction that is repeated until a condition is satisfied. 
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C. Find the erros in these C++ statements. 

 

1) #include >conio.h<    - #include<conio.h> 

2) Clrscr()    - Clrscr ( ) 

3) Cin << a    - cin >> a 

4) Cout >> a    - Cout << a 

5) Getch(;    -  getch ( ); 

6) For (c=1; c++)   - for (c = 1; C++ ) 

7) While (c<21);   - while ( c < 21 ); 

8) Cout<<”welcome;   - Cout << “welcome”; 

 

D. Explain the following in brief. 

1) header files: Header files are used in a programming language to define the layout of the data 

 contained in a program. 

2) main( ) function: The main ( ) function is the entry point of any C++ program. The main 

       function is called by the operating system by which our code is executed 

3) conditional statements: conditional statements means that the computer will run the program  

only if the condition is true.  We can use the “If …. Else” statement for this 

purpose. when the   condition after “If” is true, the computer will execute 

the instructions given after the condition. But when the condition after “If” 

is false, then computer will execute the instruction given after “Else”. This 

is called a conditional statement. 

4) loops: A loop refers to a sequence of instructions that is repeated until a particular condition is  

 satisfied.  

 

E. Answer these questions. 

1) Write a short note on the C++ programming language. 

Ans:      The mother of all computer language is the C language. C++ is an extension to the C  

  language. C++ is a high level computer programming language It is easy to understand  

and execute. It can run on different operation systems such as Windows, Linux and Mac 

Os. A C++ program always starts with header files and then defines the main () functions. 

Header files are used in a programming language to define the layout of the data contained 

in a program. All header files use the extension, .h. The main () function is the entry point 

of any C++ program. All other functions are executed inside the main functions. the void 

main( ) signifies that the main function will return nothing after its execution. C++ 

statements are written with a semicolon at the end of each statement, within curly 

brackets. 

 

 2) Write the steps to save a program in C++. 

 Ans: To save a program in C++, follow these steps: 

  1) Click on file 

  2) Click on save. The Save File as dialog box appears. 

  3) Enter the name of the file in the Save File As dialog box. 

  4) Click on OK. 

 

  



 

 

3) Define a variable. How are variable declared in C++? 

 Ans: A variable is a location in the computer memory that is used to store a value. A variable can 

 be declared in a program. The memory location is not its value. Examples of valid 

declaration of variable in C++ are as follows: 

  1) int rollinteger: data type for storing integer type of data values. 

  2) char name:  character data type for storing the combination of letters and numbers as 

                     data 

  3) float average: floating data type for storing decimal numbers. 

  4) long int total: long integer data type for stroing large integer values. 


